Issue
Non-Hosted Customer encounters an error after clicking on the Communications button within Aeries to access the ParentSquare Site.


Error Message: 
“Your single sign-on request could not be processed. Error: Object reference not set to an instance of an object.”

URL Indicator: 
The URL contains “SAML/InitiateSSO/1.”





Root Cause: 
The issue is related to the ParentSquare Single Sign-On (SSO) configuration.

Recommendations:

  1. Refresh App Pools:

    • Navigate to the Web Server settings in the Microsoft Management Console.
    • Locate the Application Pool settings.
    • Refresh the app pools.
    • Refer to the Aeries Communications ParentSquare SAML Configuration documentation for an example of Application Pools.
    • If unsure, seek assistance from the district IT team.
  2. Request a Metadata Refresh on ParentSquare’s Side:

    • Contact ParentSquare to have their metadata refreshed. This resolves the issue in 99% of cases.