Class Roster Report is showing students who are no longer in the Teacher's Class
Cause
The student's schedule was not changed correctly. The original Section was not dropped on the Classes page.
The Course Attendance page was updated manually with the Stop Date.
Solution
When there is a schedule change, the correct way to change a student's class is from the Classes page as the change cascades to the Course Attendance table.
Manual updates should not be made to the Course Attendance page as the changes do not automatically cascade to the Classes page.
- Navigate to Classes
- Select the Edit button.
- Set the End Date for the last day the student will be in the existing Section. The Start Date will automatically adjust to the next School day. Select the Delete icon to delete the existing Section. Select OK on the Confirmation prompt:
- Add the new Section. Select Save. If this is a Flex Daily school, there will be an additional Confirmation prompt regarding changing the student's Primary Class. Select OK: